Go Back  RCU Forums > RC Helicopters > Electric RC Helis > T-Rex heli
Reload this Page >

microbeast plus setup for Trex 500XT issue

Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

microbeast plus setup for Trex 500XT issue

Old 10-31-2017, 01:57 PM
  #1  
tmcgoldrick
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default microbeast plus setup for Trex 500XT issue

First electric FBL this size and needing guidance.
Setup went well and now complete. Chose parameter B "transmitter". I chose this given my desire to use start off with beginner throttle/pitch curves as well as reduced collective and cyclic throws.
I was able to accomplish the desired collective curves and endpoints but I have been unable to tame the cyclic. I was looking to get the cyclic in at around 8 degrees but DR and servo travel adjustments do not get either cyclic to move off 13.5 to 14.0 degrees.
DX8 radio/AR7700 single line RX
Measured with 0 pitch /aileron blades parallel to boom/elevator 90 degrees to boom.
What am I missing?
Thanks!
Tom

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.