Go Back  RCU Forums > RC Helicopters > Electric RC Helis > T-Rex heli
Reload this Page >

Anyone had this problem?

Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

Anyone had this problem?

Old 03-04-2006, 01:13 AM
  #1  
H0ndaJunkie
Senior Member
Thread Starter
 
Join Date: Jan 2006
Location: Bowling Green, KY
Posts: 216
Likes: 0
Received 0 Likes on 0 Posts
Default Anyone had this problem?

I assembled my 450XL HDE a little over a week ago. Almost the whole thing went together like a dream......these are really, really nice little helis. The only problem that I encountered was that the flybar control center (the see-saw)......where it screws onto the actual head........was really tight. I was careful with the locktight, but no matter what I did it just wouldn't loosen up. The flybar was able to move up and down, but it was so stiff, I was scared to try and fly it.

I ended up ordering the complete aluminum flybar assembly with bearings, and that fixed the problem of course, but I was wondering if anyone else has experienced this problem?
Old 03-04-2006, 09:45 AM
  #2  
chipperg
Senior Member
My Feedback: (9)
 
Join Date: Oct 2004
Location: richmond hill, GA
Posts: 357
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Anyone had this problem?

I had the same problem. I screwed mine into the wrong holes. It flies great now.
Old 03-04-2006, 03:50 PM
  #3  
hdoc
Senior Member
 
Join Date: Nov 2005
Location: Roslyn, NY
Posts: 428
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Anyone had this problem?

Are you sure you had the control rods (PN HH4012) correctly placed? The ball on them is offset(2.5mm) so it doesn't hit the lower control lever and matches the flybar pushrods. If you placed them on 'backwards', you WILL get binding.

Lloyd
Old 03-07-2006, 10:28 AM
  #4  
WhtBronco
Senior Member
 
WhtBronco's Avatar
 
Join Date: Oct 2002
Location: Winchester, VA
Posts: 2,084
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Anyone had this problem?

No problem here. The flybar/seesaw hub on my HDE just flops around. The main blade grips on mine are bit tight IMO, compared to my Raptor 50, but that's the only thing that seemed tight to me. It doesn't seem to effect flight performance either.
Old 03-07-2006, 06:13 PM
  #5  
jeepson33s
 
Join Date: Jan 2006
Location: kennesaw, GA
Posts: 150
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Anyone had this problem?

i had the same exact problem. i was also careful with the loctite but a little ozzed out and got into the brass fitting and the screw. only fix i could come up with was to dissasemble and get the alum. setup and now no problems! hope this helps
Old 03-08-2006, 01:10 AM
  #6  
H0ndaJunkie
Senior Member
Thread Starter
 
Join Date: Jan 2006
Location: Bowling Green, KY
Posts: 216
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Anyone had this problem?

Yeah, that's what I did.....ordered the CNC parts instead. I didn't want to go without locktight on that part but no matter what I did, it still ended up seeping out.

I flew my HDE for the first time today. I actually tried to fly it yesterday, but my ESC decided to fry....went up in smoke! Actually, I'd like to hear other people's experience with these Align ESCs also......mine was a 25G (govenor) ESC. I replaced it with a 25A today (without govenor) and it's fine. One thing I did notice is that the 25G had the heat sink attached to the outside of the heat-shrink casing......which being a computer tech, I have to say that it was certainly not a good thermal connection.......the new 25A has the heat sink directly connected to the ESC.

So anyway, I flew the Heli for the first time today in a warehouse.........WOW......I'm totally impressed, it's SO stable!!! I have a futaba computer heli transmitter, with a futaba FM reciever, and 3 futaba servos, 1 Hitec servo on the tail, and a GY401 gyro. The gyro sticks like glue!!

Considering that I switched from a Walkera 56, to this 450XL HDE, the difference is incredible! I love this little heli!

I've already ordered a 450XL CDE......with the CNC seesaw.......so then I'll have the mechanical pitch version, and the e-CCPM version. ;-)

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.