Go Back  RCU Forums > RC Helicopters > Electric RC Helis > T-Rex heli
 just got trex se, problems.. >

just got trex se, problems..

Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

just got trex se, problems..

Old 11-11-2006, 11:04 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Nov 2005
Location: wasilla, AK
Posts: 360
Likes: 0
Received 0 Likes on 0 Posts
Default just got trex se, problems..

i just got a trex 450 se and i put together ok, well prob is servos. i bought the park flyer spectrum with the 4 servos and i keep stripping or breaking the aileron servo. im very new to setting up helis so i dont quite understand what im doing yet. any advice? i have spent alot of time on the simulator flying but no idea how to set up pc's and the like of. any help is great.
Old 11-12-2006, 12:53 AM
  #2  
 
FLYMIKE's Avatar
 
Join Date: Jun 2006
Location: Salt Lake City, UT
Posts: 605
Likes: 0
Received 0 Likes on 0 Posts
Default RE: just got trex se, problems..

those servos are the same as the ones in the blade heli and everyone says they suck! try the hs65mg servos. I have had a few crashes and there still going. Mike

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.