Go Back  RCU Forums > RC Helicopters > Electric RC Helis > T-Rex heli
 First Flight on my SA today!!!!! >

First Flight on my SA today!!!!!

Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

First Flight on my SA today!!!!!

Old 11-20-2006, 10:28 PM
  #1  
Member
Thread Starter
My Feedback: (8)
 
Join Date: Aug 2005
Location: Peachtree City, GA
Posts: 66
Likes: 0
Received 0 Likes on 0 Posts
Default First Flight on my SA today!!!!!

I finally finished my thousand dollar project, and it feels great. I built my sa with the align 3550 kv motor, align 35 amp esc, hs-65mg servos, Futaba 401 gyro with 9650 digital tail, and spektrum dx6 radio. Last night i couldn't wait to maiden it, so I did it inside. Can you believe it was so perfectly set up all i needed was one click of left aieleron. My first hover ever and i did it in about a 8 x 8 space in my living room. Wow. This thing is so stable.....I am going to have a lot of fun with this. I have flown the sim quite a bit, but the trex seems alot more stable than some of the helis on there. I went out today and ran 2 battery packs through it just hovering tail in and had a good time. Just wanted to share my experience. Thanks.
Old 11-21-2006, 06:09 AM
  #2  
 
VinceHerman's Avatar
 
Join Date: Sep 2002
Location: Cleveland, OH
Posts: 2,304
Likes: 0
Received 1 Like on 1 Post
Default RE: First Flight on my SA today!!!!!

Congrats!
Old 11-29-2006, 05:42 AM
  #3  
Junior Member
 
Join Date: Nov 2006
Location: GeorgetownPenang, MALAYSIA
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default RE: First Flight on my SA today!!!!!

congrates to u brother!i'm getting my t-rex tonite!hope i can fly as good as u..cheers~~~
Old 12-02-2006, 09:31 PM
  #4  
Member
 
Join Date: Mar 2006
Location: Burlington, KY
Posts: 32
Likes: 0
Received 0 Likes on 0 Posts
Default RE: First Flight on my SA today!!!!!

Maidened my SA today! Hovered tail in for a battery load. The only complaint about the flight was some occasional twitchiness in the tail rotor. I'm running the Align gyro with a Hi Tec servo. Any way to dial that in with gain + or - ? Or is that about the best I can expect from that gyro. Holds a general heading, but it looks like it's really hunting. Also noted a slight amount of white nylon dust shedding from the main gear. I have what I think is a good mesh, but I have no frame of reference as this is my first experience with a heli. Should I back the motor off the pinion just a pinch, or run it for another flight to see if it stops. Seems to be plenty free, with no binding on any quadrant, and just the slightest amount of play.

Overall, I'm thrilled with this machine. Not nearly as scary as I was led to believe. I'll roll right into forward flight once the twitchy TR is fixed. Better get parts on order!!!

Don
Old 12-02-2006, 10:38 PM
  #5  
Member
 
Join Date: Aug 2006
Location: Willard, OH
Posts: 74
Likes: 0
Received 0 Likes on 0 Posts
Default RE: First Flight on my SA today!!!!!

i saw a few peoples pushrods were tight in the boom holder. try drilling that out a little, and lubing it.
what servo are you using? fast enough? enough torque?
Old 12-03-2006, 02:13 AM
  #6  
Member
 
Join Date: Oct 2006
Location: , MI
Posts: 42
Likes: 0
Received 0 Likes on 0 Posts
Default RE: First Flight on my SA today!!!!!


ORIGINAL: thermlin

i saw a few peoples pushrods were tight in the boom holder. try drilling that out a little, and lubing it.
what servo are you using? fast enough? enough torque?
The best thing to do is to not let the pushrod go through the boom/strut holder at all. Most servo heads stick out too far. If there is any bend to the pushrod at all, pop it out of there.
Old 12-03-2006, 07:36 AM
  #7  
Senior Member
 
Jellyson's Avatar
 
Join Date: Nov 2006
Location: Toronto, ON, CANADA
Posts: 920
Likes: 0
Received 0 Likes on 0 Posts
Default RE: First Flight on my SA today!!!!!

You are using the tailboom servo mount right? What hitec servo?
I have the HS65 and Align RCE-500X gyro on my MX400Pro with TRex tailfeathers, and it holds the head like it was on a rail and gives precise and even yaws in both directions in HH mode, and I've got it trimmed out so I need no rudder trim in hover in SR mode. I'm using the CF pushrod, not going thru the guide at all, and a good grade of synthetic grease on the tail pitch slider, which tends to bind at extreme leftmost travel.
I put the gyro in a different place though...maybe that is why I get such good performance from the cheapo setup.
To set gear mesh correctly slip a piece of typing paper between the pinion and main gear, then tighten down the motor. Turn the gears to eject the paper--perfect .004 backlash!
Some white dust is normal.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.