Notices
Toy-Grade RC Products Post in here about toy-grade rc products and the mods you''re making to them. These typically fall in the sub $100 range.

Colco thunderbird problems

Old 06-02-2020, 03:39 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2020
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Colco thunderbird problems

Hi,
I've inherited a Colco thunderbird, which I've just got around to trying to fly.
My problem is that when I power up quickly, nothing much happens, other than the gain light flashes.
If I do it slowly, the main rotor and tail rotor spin, getting up speed until they both suddenly stop.
During getting up speed the power, setup and gain lights are flashing and the servos are going crazy too!
I'm pretty sure that the battery is OK (Nimh) and have had it on charge for a good 24 hours.

I did a search for this problem and noticed that the same question was asked here a few years ago, but it doesn't look like anyone replied.

I'm guessing that this is not such an uncommon problem?
I appreciate any help you can offer to get it going.
Thanks very much.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.