Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic
Reload this Page >

T-18 Guidance

Notices
Turbine Clinic Get direct support from the major turbine manufacturer support reps in here.

T-18 Guidance

Old 12-07-2016, 12:46 PM
  #1  
Dura Flame
Thread Starter
 
Dura Flame's Avatar
 
Join Date: Dec 2014
Posts: 65
Likes: 0
Received 0 Likes on 0 Posts
Default T-18 Guidance

I recently acquired a new Jet Legand T-18 turbine, and am having some problems getting the ecu to respond correctly. The specific problemI am having is after programing the ecu to the transmitter, when I raise thethrottle trim to the full position, the ecu displays “ready”. When thethrottle is then advanced to the full position, the ecu displays “cooling”, andthe starter engages. When the throttle is then lowered to the idleposition the ecu displays “burner on” then after a short time displays “glowbad”. I have checked to make sure the start, run and radio settings arecorrect. Can anyone please advise as to what the problem may be, and how toresolve it? I am very familiar with the Xicoy based FADEC ECU and their operation.

Last edited by Dura Flame; 12-07-2016 at 12:49 PM.
Old 12-08-2016, 10:38 PM
  #2  
more
 
Join Date: Feb 2011
Posts: 61
Likes: 0
Received 3 Likes on 2 Posts
Default

The squence is correct.Maybe your motor have a problem with glowplug.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.