Notices
Walkera Helis - Dragonfly, etc.. Discuss Walkera Dragonfly Helis and any Walkera products in this forum

Walkera 60 power on problems?!?

Old 07-06-2013, 06:19 AM
  #1  
flyhighrcs79
Junior Member
Thread Starter
 
Join Date: Jul 2013
Location: Cleveland, OH
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Walkera 60 power on problems?!?

Hello members of RCUniverse. I have a weird problem with my walkera 60 heli. Some info about the chopper, it is a wk-0701 tx, rx701 pcm, G010 Gyro and B20A speed controller. What it was, I flipped the reverse switch on the gyro with the tx being in normal mode and ever since then, whenever I power up the heli its servos go fubar. Both the aileron and rudders move like if the heli would moving forward or the tail would be moving left or right( top and tail rotor) instead of remaining straight. The gyro light is flashing as well when this happens and the status light on the tx is purple(walkera lamp) I don't hear the servos making any kind of shuddering kind of noises and the heli has no throttle either. Has anybody experienced the same problem or know whats going on with this chopper, maybe adjustments or bad pcm? Thanks


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.