Notices
Walkera Helis - Dragonfly, etc.. Discuss Walkera Dragonfly Helis and any Walkera products in this forum

5G6 5#6 Lift issues????

Old 11-21-2008, 01:09 PM
  #1  
sn00p
Senior Member
Thread Starter
 
Join Date: Jan 2008
Location: , UNITED KINGDOM
Posts: 187
Likes: 0
Received 0 Likes on 0 Posts
Default 5G6 5#6 Lift issues????

Basically i have a 5#6 plastic head version and decided to upgrade to the 5G6 metal head.... so i purchased

Ali main shaft (upgrade)
Ali blade grip holders (upgrade)
ali swash plate

I even went the full hog and got the white 5G6 blades and ali tube tail boom.

Since doing this i now only get like 1 min of good flight from all my batteries then the heli just doesnt seem to have enough power to keep its ass off the ground

I am 100% the batteries are good as ive tried them in another heli and they are fine. I pressumed it was weight issue although the manuals say there is a only a few grams different between the 2 helis so i removed my motor heatsinks and the tail boom which came to more than the weight difference and still only get a real short flight time. Both inner and outer shaft seem to be free, the drive gears are all aligned correctly. Anyone else had this problem or know a fix???

Really anoyed i spent £50 on the heli and another £50 upgrading only for it not to fly as well as before??? Anything i could have done when upgrading the parts that could cause the problem???

Im pressuming both motors are running equal and the thing is it will fly perfectly for a minute maybe 2 max them it just seems the batteries die. Re-charge and you get another perfect minute or 2. When using the same batteries in another heli i get the expected 7 minute flight times...

im guessing something is causing the batteries to die prematurely. Seems i have no binding issues from shafts/motors/blades i dunno maybe the 3 in 1 is faulty??? just seems strange this has only happed since the upgrade.

Many Thanks in advance.
Old 04-23-2010, 04:09 AM
  #2  
Rhubear
Junior Member
 
Join Date: Apr 2010
Location: MaidenheadBerkshire, UNITED KINGDOM
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 5G6 5#6 Lift issues????

Check out this thread - http://www.rcuniverse.com/forum/m_80...tm.htm#8048374

User BrianNZ discovers a bearings problem with his Walkera 5G6. Replacing the bearings (or whole housing) enabled his heli to fly again.

Problem with no-lift is not usually the batt, or motors apparently.

I'm currently having the same problem with my 5G6, hence my "research" here!

HTH

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.