Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > Wren Turbines USA
Reload this Page >

Wren Super Sport Kero Programming

Notices
Wren Turbines USA Wren USA no longer providing support for their turbines. We are converting this forum into a member supported support forum. This means members will solve members problems

Wren Super Sport Kero Programming

Old 03-07-2021, 11:43 AM
  #1  
edwarda10pilot
Thread Starter
My Feedback: (3)
 
Join Date: Mar 2002
Location: Seguin, TX
Posts: 549
Likes: 0
Received 2 Likes on 2 Posts
Default Wren Super Sport Kero Programming

Hello all. I have a Wren super Sport that has been converted from gas start to kero start. The engine is a really great running engine on gas start so it has been converted to kero start. It has the Wren/Turbine Solutions start and run valves, the correct kero plug and the ECU has been programmed to what I thought are the correct values for a kero start. However, the engine goes thru the start sequence and I get a poof like the kero is ignited and the engine RPM and temp go up but the starter slows, I then get another poof like the kero has ignited again but the kero still does not ignite. After a couple of these attempts the starter disengages and the engine does not start. As I said, the engine runs great when started on gas but it will not start on kero so I suspect that I have an ECU programming value that is not correct. Incidentally, I have changed the kero plug glow plug voltages numerous times and still "no joy".

Can any of you that have Super Sport on kero start please provide me with the Start and Run programming values you have found to be successful? I have contacted Turbine solutions and asked for the programming values but have yet to receive any response. Amy assistance would be greatly appreciated.

Thanks very much,
Ed
Old 03-08-2021, 10:04 AM
  #2  
JSF-TC
My Feedback: (2)
 
JSF-TC's Avatar
 
Join Date: May 2002
Location: Fort Worth, TX
Posts: 1,301
Likes: 0
Received 134 Likes on 78 Posts
Default

Ed,

When you converted it back to Propane start, did you change any of the start parameters?

When I used it last, it started smoothly on kero, but I don't have a copy of the settings saved, otherwise I'd send them to you.

From your description, it sounds like you need to increase the starting kero flow rate - I can't remember the ECU term that you need, but it will be under the start menu.

What ECU battery are you using, and is it fully charged? - kero start needs a fairly high current supply capability.

Paul
Old 03-08-2021, 11:43 AM
  #3  
David Gladwin
 
David Gladwin's Avatar
 
Join Date: Feb 2002
Location: CookhamBerkshire, UNITED KINGDOM
Posts: 3,911
Received 138 Likes on 89 Posts
Default

I have a Supersport, kero start with xicoy ECU. I ran it last Saturday after a long layoff, Covid, started and ran beautifully.

If you have a. xicoy, let me know and I can give you the settings.
DG
Old 03-08-2021, 01:57 PM
  #4  
edwarda10pilot
Thread Starter
My Feedback: (3)
 
Join Date: Mar 2002
Location: Seguin, TX
Posts: 549
Likes: 0
Received 2 Likes on 2 Posts
Default

Originally Posted by JSF-TC
Ed,

When you converted it back to Propane start, did you change any of the start parameters?

When I used it last, it started smoothly on kero, but I don't have a copy of the settings saved, otherwise I'd send them to you.

From your description, it sounds like you need to increase the starting kero flow rate - I can't remember the ECU term that you need, but it will be under the start menu.

What ECU battery are you using, and is it fully charged? - kero start needs a fairly high current supply capability.

Paul
Hi Paul. When I got it it started just fine twice then it would not start again. I just set it aside and worked on other projects. I am using a fully charged 2S lipo 5000 mah. When I converted it back to gas start I did change the glow plug voltage but nothing else. I then returned it to kero start since I knew the engine ran fine, it must be a programming issue. I have tried changing the kero plug voltage (initially it was 6.9 volts and I have tried it at 7, 7.2 , and 74.) I have increased the plug pre heat time, the fuel flow% and the auto start settings all with no success. I removed the kero plug and hooked it up to a 6.6 volt LiFe and the element heats up but does not get white hot as some of my other conversions plugs do.

I have asked Paul at Turbine Solutions for help over the past two weeks and got nothing. I have ordered a new kero plug to see if it is the problem.

Thanks for chiming in and offering assistance. I am sure I will get this figured out. I don't need the engine immediately and this is a good learning process for me..

Thanks again,
Ed
Old 03-08-2021, 02:03 PM
  #5  
edwarda10pilot
Thread Starter
My Feedback: (3)
 
Join Date: Mar 2002
Location: Seguin, TX
Posts: 549
Likes: 0
Received 2 Likes on 2 Posts
Default

Originally Posted by David Gladwin
I have a Supersport, kero start with xicoy ECU. I ran it last Saturday after a long layoff, Covid, started and ran beautifully.

If you have a. xicoy, let me know and I can give you the settings.
DG
Hi David. I do have a Xicoy ECU. I would appreciate it if you could give me the programming values for the engine . I am in need of all of the values for the start and run segments of the ECU.
The stuff I need is stuff like :
Auto start, pump start ramp
start power @ ignition, start power fuel ramp, etc. etc.
For the Run segment I need to know:
Accel Delay, Decel Delay, Stability delay, pump limit.

Thanks again to all for your help,
Sincerely,
Ed
Old 03-09-2021, 02:26 AM
  #6  
David Gladwin
 
David Gladwin's Avatar
 
Join Date: Feb 2002
Location: CookhamBerkshire, UNITED KINGDOM
Posts: 3,911
Received 138 Likes on 89 Posts
Default

Here are the settings on my Ss this morning as have been used for 30 or so flights.
pump start 24
start ramp 003
glow plug power 6.5 v
start power at ign 074
start power @fuel ramp 070
rpm 100 % 25,000
rpm off 30,000
reconnect 26,000
rpm ign 5000
pump power ign 028
min flow 57%
egt end preheat 200
rpm end prehear 10,000
fuel ramp 23,000
preheat fuel 65

RUN PARAMETERS:
Full power 160,000
idle 45,000
stop 30,000
start min egt 100
max 800
accel 008
decel 012
stab 100
pump limit 0752.

However, as Mike and Gaspar emphasise these are MY settings and all pumps vary a little so may not be perfect for yours.
That said, you could hse them as a starting point and see how you get on .

Good luck,
David.
The following users liked this post:
rjbob (11-11-2022)
Old 03-09-2021, 05:44 AM
  #7  
edwarda10pilot
Thread Starter
My Feedback: (3)
 
Join Date: Mar 2002
Location: Seguin, TX
Posts: 549
Likes: 0
Received 2 Likes on 2 Posts
Default Wren Super Sport Kero Programming

Hello David. Thank you so very much for this information. It is exactly what i was looking for and what I needed. I will take these settings and use them as a base line/starting point. I do understand that they are just a starting point. I believe that what has happened is that somewhere along the line I have made some changes to the ECU, not recorded them and not can not get back to the baseline for this engine. This is my first Wren and they are wonderful little engines so I would even run it as a gas start if I could not get it to start on kero. Hopefully, however, I can get back to a baseline

Again, thanks so much for all of your help. I am planning on a trip to Europe this fall and planning a trip to England so perhaps I can buy you a "pint".

Sincerely,
Ed Valls
The following users liked this post:
rjbob (03-25-2021)
Old 03-09-2021, 05:57 AM
  #8  
David Gladwin
 
David Gladwin's Avatar
 
Join Date: Feb 2002
Location: CookhamBerkshire, UNITED KINGDOM
Posts: 3,911
Received 138 Likes on 89 Posts
Default

It's always a pleasure to help like this, its what RCU is really for, and I wish you every success, the SS is a splendid engine .

As a matter of interest do let us know how you get on.

No pint required, come and join us at a jet meet !

kind regards,

David.
The following users liked this post:
rjbob (03-25-2021)
Old 03-09-2021, 06:32 AM
  #9  
edwarda10pilot
Thread Starter
My Feedback: (3)
 
Join Date: Mar 2002
Location: Seguin, TX
Posts: 549
Likes: 0
Received 2 Likes on 2 Posts
Default

David, thanks again. I have booked a trip to Europe for late August until mid September. I have a friend who travels between Germany and the U.S. and he has offered to "show me around" various parts of Europe. My hope is to visit the beaches of Normandy, do some aviation/WW 2 museum sightseeing in England and visit some sites in Paris and Germany. I should be there for about 3 weeks and plan on attending the 2021 Jet Power Fair before returning. I will make every effort to make contact with you. I will send you a PM with my contact info.

Thanks again,
Ed
The following users liked this post:
rjbob (11-11-2022)

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.