Go Back  RCU Forums > RC Helicopters > XHeli.com Support Forum
 Throttle wont respond...smoke? >

Throttle wont respond...smoke?

Notices
XHeli.com Support Forum If you have a question, problem or concern about your product from xheli.com, please use this forum to get answers to your questions.

Throttle wont respond...smoke?

Old 08-03-2011, 07:49 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jul 2011
Location: Brookfield, WI
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default Throttle wont respond...smoke?

To start, I have an Exceed G2..and this was on my first flight.

I tried hovering the heli today, and was able to adjust the trim features enough to get it to hover, and then it happened...

The lipo battery inside the canopy started to rub on the motor and smoke emitted from the inside.

When i turned everything off and unplugged it, i noticed the battery casing was frayed slightly but the battery seemed to be ok. The motor had threads from the outside casing of the battery on it.

When I tried turning it all back on again, all of the controls work except for the throttle. When I press up on the throttle, the gyros tilt downward but there is no rotation or power to the heli, even at 100%.

If anyone has anything helpful to add, that would be greatly appreciated. This was my first day out with the heli and this happened. I am semi bummed

What steps can i take/what could it be?

Also I wanted to add that when i plugged it back in to check for power, there WASpower, but there was also a smell (like an electrical burning smell) and a buzzing coming from what sounded like the receiver or something. The motor just has a few marks on it from spinning up against the back of the battery when i had it in the canopy.

Thanks...I would really appreciate some help with this, as I am a newbie...had a nice hover and then this happened.
Old 08-03-2011, 10:21 AM
  #2  
Senior Member
 
Join Date: Sep 2010
Location: la puente, CA, UNITED KINGDOM
Posts: 268
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Throttle wont respond...smoke?

Hi may I have your order number please ?


Eric
Old 08-03-2011, 01:22 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Jul 2011
Location: Brookfield, WI
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Throttle wont respond...smoke?

Eric,

the order number is yhst-94582​326164583-​412772

I went to an RC hobby store today and talked to one of the techs. He said the problem seems to be the servo (i think) - whatever the battery looking thing is by the skids. I have no idea how this happened as I just purchased it.

Thanks,
Matt
Old 08-03-2011, 01:25 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Jul 2011
Location: Brookfield, WI
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Throttle wont respond...smoke?

To be honest, im not sure if it is called the servo or not....would this be an exchange or what? Thanks eric
Old 08-04-2011, 10:46 AM
  #5  
Senior Member
 
Join Date: Sep 2010
Location: la puente, CA, UNITED KINGDOM
Posts: 268
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Throttle wont respond...smoke?

Hi there is something wrong with my system could you give PM me with your information please I'm so sorry about that. I need your zip code and name or a email address.


Eric

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.