Notices
YS Engines Support Direct support from YS Performance Engines by Dave Shadel

starting 63s

Old 06-22-2007, 07:10 AM
  #1  
stoll77
Junior Member
Thread Starter
My Feedback: (1)
 
Join Date: Oct 2003
Location: Cincinnati, OH
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default starting 63s

I'm about to fire up my new 63s this weekend. I noticed the regulator was screwed below the point of being flush. Is that correct? Any tricks for successful starting I should know as this is my first "supercharged" engine.
Thanks in advance.
Old 06-22-2007, 09:14 AM
  #2  
arobatx
 
Join Date: Jan 2006
Location: Kalona, IA
Posts: 2,517
Likes: 0
Received 0 Likes on 0 Posts
Default RE: starting 63s

Here is a pretty decent review of things: http://www.probuild-uk.co.uk/factsheets/ys_engines.php
Old 06-22-2007, 09:30 AM
  #3  
stoll77
Junior Member
Thread Starter
My Feedback: (1)
 
Join Date: Oct 2003
Location: Cincinnati, OH
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default RE: starting 63s

Thanks
Old 06-24-2007, 06:13 PM
  #4  
Newc
Senior Member
 
Join Date: Oct 2002
Location: Leesburg, IN
Posts: 1,047
Likes: 0
Received 0 Likes on 0 Posts
Default RE: starting 63s

Here are the instructions from the YS website...
Attached Thumbnails Click image for larger version

Name:	Nk27784.jpg
Views:	6
Size:	90.3 KB
ID:	710118   Click image for larger version

Name:	Id95826.jpg
Views:	6
Size:	130.9 KB
ID:	710119   Click image for larger version

Name:	Ej12613.jpg
Views:	8
Size:	59.0 KB
ID:	710120  
Old 06-24-2007, 07:35 PM
  #5  
Troy Newman
Senior Member
 
Join Date: Dec 2001
Location: Goodyear, AZ
Posts: 2,429
Likes: 0
Received 3 Likes on 2 Posts
Default RE: starting 63s

The new "remote" regulator system works the same way as far as adjustments but it is no longer flush with the case for a baseline setting. My 110S is about 1/32-1/64 inside of flush with the housing.

Troy Newman
Team YS
Old 06-25-2007, 06:42 AM
  #6  
stoll77
Junior Member
Thread Starter
My Feedback: (1)
 
Join Date: Oct 2003
Location: Cincinnati, OH
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
Default RE: starting 63s

Thanks for the help everyone.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.