Notices
ZDZ & RCS Support Direct support from Mike Dooley of RC Showcase for all your ZDZ and RCS Engine questions.

Rough running = bang bang bang

Old 03-02-2012, 09:31 AM
  #1  
Dead Eye Dick
Member
Thread Starter
 
Join Date: Apr 2005
Location: Wales, UNITED KINGDOM
Posts: 85
Likes: 0
Received 0 Likes on 0 Posts
Default Rough running = bang bang bang

My ZDZ 50NG has run flawlessly for a couple of years and then today had a perfect flight without any problems and on the second flight she suddenly stopped throttling up and one could hear the engine barking, bang bang bang but ticked over sweat as ever when I reduced throttle. She wouldn't open up again. I was lucky to land on idle.

Checked everything, nothing loose, sensor and plug looked fine, throttle servo operating correctly. Restarted and she ran as sweet usual, as nothing was wrong. A perfect tick over and throttled up several times OK in the pits. Never missed a beat. Taxied out to take off, pre throttle up check and bang bang bang, no pick up. It sounded like ignition. She would run flawslessly on idle but refused to throttle up without barking bang bang bang and no pick up on revs. Suggestions welcome?
Old 05-17-2012, 01:05 PM
  #2  
Dead Eye Dick
Member
Thread Starter
 
Join Date: Apr 2005
Location: Wales, UNITED KINGDOM
Posts: 85
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Rough running = bang bang bang

OK found the source of my problems .... ignition battery was on the way out. Voltage had dropped right off. Replaced with a new battery and all OK.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.