Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Caldera 3.0 issues.....

Reply
Old 08-18-2012, 05:37 PM
  #1
terrywolfpack
Thread Starter
 
Join Date: Jan 2009
Location: Kiowa, KS
Posts: 58
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Caldera 3.0 issues.....

Hello everyone i'm having issues with the caldera 3.0 brake set up??? When i start it up the break act like it doesn't want to work and i need a pic of the break setup if someone has it? and if there are any other problems with these caldera please let me know? just trying to fix for a friend...Terry
terrywolfpack is offline  
Reply With Quote
Old 08-18-2012, 06:22 PM
  #2
Jjm3
 
Join Date: Feb 2012
Location: Boardman, OH
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Caldera 3.0 issues.....

I had a similar issue , I went to Redcat site they have detailed pics you can see how their set up
Jjm3 is offline  
Reply With Quote
Old 08-18-2012, 08:34 PM
  #3
Dads like rc too
 
Join Date: Nov 2011
Location: myrtle beach, SC
Posts: 754
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Caldera 3.0 issues.....


Quote:
ORIGINAL: terrywolfpack

Hello everyone i'm having issues with the caldera 3.0 brake set up??? When i start it up the break act like it doesn't want to work and i need a pic of the break setup if someone has it? and if there are any other problems with these caldera please let me know? just trying to fix for a friend...Terry
There could be a few issues. Is the throttle trim bumped up, this will affect your brakes. If that's good did you check the brake pad screws, these get loose from time to time. Then of course the linkage...has it been adjusted lately? Also the brake disc itself needs to be scuffed up with some heavy grit sandpaper occasionally.
Dads like rc too is offline  
Reply With Quote
Old 08-19-2012, 06:40 AM
  #4
terrywolfpack
Thread Starter
 
Join Date: Jan 2009
Location: Kiowa, KS
Posts: 58
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Caldera 3.0 issues.....

Thanks Jjm3 will look that up, and Dad like rc too thanks for the info.. I had a gal friend get this and first time out she burnt up plastic spur gear and hit a pole and replaced it and when i was working on tunning it yesterday i noticed the linkage for the brake all apart and thoought thats why it doesn't stop...lol.. I have alot of redcat stuff through trades and what not good product and this is new to me because never had any problems with them until this caldera 3.0 came around...lol... But thats the fun thing in the hobby is tinkering with stuff.....I appreciate the input guys thanks and god bless...Terry
terrywolfpack is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:03 PM.