RCU Forums - View Single Post - Elevator sliding trim not working
View Single Post
Old 12-13-2020, 06:00 PM
  #3  
raydebs
 
Join Date: May 2005
Location: Boise, ID
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by pancake View Post
Elevator sliding trim on my infinity and a vanguard radio doesn’t work. Tried different 92765 receivers and still no elevator adjustments can be made . Any suggestions.
I have the same problem with my Infinity 1000 and a couple other radios as well. It has been more than 15 years since I used my RC equipment, and now that I am trying again, I have found that a lot needs to be fixed.

I think the problem with the sliding trim is that the pots have bound up. I think it is because the lubricant has turned to glue. I was able to turn one of the pots with a screwdriver to free it up, but it still feels like a stick in the mud. I just ordered some Isopropyl Alcohol to clean them and see if I can get the radio back to working condition. If the cleaning doesn't work, then I will be looking for replacement pots to see if that route works.

I have a Futaba -T7UHP Super radio that both gimbals have frozen up. Probably the same problem.

Anyone else had any experience with these types of problems?

Thank you,
Ray