Go Back  RCU Forums > Radios, Batteries, Clubhouse and more > Batteries & Chargers
Reload this Page >

Celectra beeps once and won't charge...

Notices
Batteries & Chargers Nicads, Nickel Metal Hydride, Lithium, LiPoly, Chargers, Cyclers, etc...

Celectra beeps once and won't charge...

Old 02-16-2006, 10:35 PM
  #1  
hogfan
Junior Member
Thread Starter
 
Join Date: Oct 2005
Location: , AR
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default Celectra beeps once and won't charge...

Hi,
I have been using a Celectra for about 4 or 5 months now. Yesterday, when I plugged the charger in, it beeped once and the light blinked once. With my battery plugged in, I get no response from pushing the red "start/select" button. I tried it with two different batteries and got the same response. I even tried the "force charge" feature and got absolutely nothing!

Any suggestions?
Old 02-17-2006, 07:54 PM
  #2  
Hugeone
Junior Member
My Feedback: (6)
 
Join Date: Jan 2005
Location: , QC, CANADA
Posts: 15
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Celectra beeps once and won't charge...

With what power source are you feeding that charger?
Old 02-20-2006, 07:55 PM
  #3  
hogfan
Junior Member
Thread Starter
 
Join Date: Oct 2005
Location: , AR
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Celectra beeps once and won't charge...

I have been using a 12v transformer,
input: 120 volt AC 60Hz, 10 W
output: 12 volt DC 500mA

This should work, correct?

Thanks, Ryan
Old 02-20-2006, 08:35 PM
  #4  
pilotpete2
 
pilotpete2's Avatar
 
Join Date: Oct 2002
Location: Lyndonville, VT
Posts: 3,305
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Celectra beeps once and won't charge...

Hey Hogfan,

You didn't say what size packs you are trying to charge, and at what rate, but a 500 mah power supply (wal-wart I assume) is probably totally inadequate[&o]. Do you have the ability to try it with a car battery as your 12V source? If that works , you need a bigger power supply.
Good Luck,

Pete
Old 02-21-2006, 12:13 AM
  #5  
hogfan
Junior Member
Thread Starter
 
Join Date: Oct 2005
Location: , AR
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Celectra beeps once and won't charge...

Well,
I've been charging a 730 mA 2 cell. I am setting the celectra to charge at the 500mA setting. I figured that would work.

I hooked it up to my 12V boat battery and got the same response from the charger - basically nothing after the first beep. Like I said, I can't even get the charger to "force charge"...when I hold the start button down to do the force charge, I get no response.

It's weird because I have been using this power source for the last ~25 charges with no problems and now it is acting up.
Old 02-21-2006, 10:39 AM
  #6  
pilotpete2
 
pilotpete2's Avatar
 
Join Date: Oct 2002
Location: Lyndonville, VT
Posts: 3,305
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Celectra beeps once and won't charge...

Hey Hogfan,

Bummer hogfan, I would contact the distributor of the Celectra, it sounds like there is a problem with the unit.
The power supply you are using can hardly handle the load you are putting on it, no way you can charge at a higher rate, look for an old PC power supply, even a wimpy one will usually be rated at 5A on the 12V output.
Good Luck,

Pete

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.