Go Back  RCU Forums > Electric Aircraft Universe > Electric General Discussion
Reload this Page >

EVADER - Motor Beeps Quick Question:

Notices
Electric General Discussion General Discussion forum about rc electric related aircraft, accessories, flight, tips, etc.

EVADER - Motor Beeps Quick Question:

Old 08-12-2017, 09:07 AM
  #1  
Electriceddie
Thread Starter
 
Electriceddie's Avatar
 
Join Date: Aug 2002
Location: Massapequa Park, NY
Posts: 654
Likes: 0
Received 0 Likes on 0 Posts
Default EVADER - Motor Beeps Quick Question:

Hi Guys,

I am fairly new to electrics. I have an Evader from Great Planes with a small electric ducted fan unit which seems to be quit powerful. Controlling the power to the motor and the servos is a Thunderbird ESC from Castle. Powered by a Lipo 2200mAh 30C 14.8V 33Wh.

My Question: I start by turning on the Trans (Futaba 9C Super) then I connect the battery. I get the 4 quick beeps and the then 2 sec’s. later the musical tones. When I raise the throttle to test the range it seems to works fine for the most part. (I have another Question about that I will pose later) Now about every 45 seconds I hear a beep. It sounds like it is coming from the motor. I believe this is normal.

Can someone please confirm this?



Thanks
Eddie

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.