Go Back  RCU Forums > Electric Aircraft Universe > Electric RC Jets
Reload this Page >

70mm EDF jet pulsating?

Notices
Electric RC Jets Discuss rc electric ducted fan or radio control prop jets here.

70mm EDF jet pulsating?

Old 11-25-2021, 07:44 AM
  #1  
TomTreese
Thread Starter
My Feedback: (1)
 
Join Date: Jul 2005
Location: Williamsburg, VA
Posts: 582
Likes: 0
Received 1 Like on 1 Post
Question 70mm EDF jet pulsating?

I have a HABU 70mm EDF jet from E-flite/Horizon. Yesterday after two successful flights I installed a fully charged Glacier 4s 3300 45C battery, which I have used for 2 months in this aircraft, The motor ran for about 6 seconds and started to pulsate and then shut off.
I was able to land the plane with out any damage.
I tried again on the work bench with the same result. I tried it with the batteries from the two previous flight with no issue??? When I tried it with a battery checker (I don't have an IR checker yet) attached ,It happens when the the voltage goes below 13.75. Which is probably the ESC 's low voltage cutoff?? I put the batteries in another 65mm EDF and it does not happen?? My other batteries are HRB 4s 3300 60C bought at the same time. About 6 months old.
So! Is it the Battery,,, ESC... or Motor??? Bye Saturday I'll be able to measure the IR, which , will help?? The Glacier's are the only one that go below 13.75V.
Old 11-26-2021, 03:01 PM
  #2  
ron_van_sommeren
 
ron_van_sommeren's Avatar
 
Join Date: Sep 2002
Location: Nijmegen / Nederland
Posts: 630
Likes: 0
Received 22 Likes on 17 Posts
Default

Battery is not up to the job it seems.
Did you measure battery voltage sag and battery current at wide open throttle Tom?
RPM is also handy for debugging.

Prettig weekend Ron
Without a watt-meter you're in the dark ... until something starts to glow
E-flight calculators watt-meters diy motor tips&tricks Cumulus MFC


Last edited by ron_van_sommeren; 11-26-2021 at 03:03 PM.
Old 11-26-2021, 03:53 PM
  #3  
TomTreese
Thread Starter
My Feedback: (1)
 
Join Date: Jul 2005
Location: Williamsburg, VA
Posts: 582
Likes: 0
Received 1 Like on 1 Post
Default

After a lot of Watt meter and cell and motor checking. I replaced the ESC, since I had a spare, Now the only battery that cuts out due to the LVC is that original problem Glacier. Two other 3300 glaciers and all the HRB's keep the Voltage above 14.5 and run well.
It may have been the ECS connector??? But it was definitely that Glacier 3300 battery.

Yes, I did measure all those perimeters with a watt meter and cell checker and the bad Glacier was the only one fully charged to go below 13.5 V.(and it did it quickly). that appears to be the LVC.

Thanks for your response.


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.