Notices
Gas Engines Questions or comments about gas engines can be posted here

Sachs 3.2 ignition/sensor problem

Old 06-11-2005, 10:49 PM
  #1  
Birddog-RCU
Thread Starter
My Feedback: (62)
 
Join Date: Jan 2002
Location: Saratoga Springs, UT
Posts: 1,169
Likes: 0
Received 0 Likes on 0 Posts
Default Sachs 3.2 ignition/sensor problem

I have a Sachs 3.2 that will run great for 10 flights or so and then the hall sensor will fail. This has happened to me twice now. What could be causing this?
Old 06-12-2005, 12:11 AM
  #2  
tkg
My Feedback: (1)
 
Join Date: Jan 2002
Location: Riverton, WY
Posts: 3,114
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Sachs 3.2 ignition/sensor problem

Hall switch killers.....
1. Bad ground for spark plug.
2. Old engine with sloppy timing ring, sensor rubs on prop hub
3. Vibration and a broken wire at the sensor.
Old 06-14-2005, 09:49 PM
  #3  
Birddog-RCU
Thread Starter
My Feedback: (62)
 
Join Date: Jan 2002
Location: Saratoga Springs, UT
Posts: 1,169
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Sachs 3.2 ignition/sensor problem

Thanks for the info TKG

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.