Go Back  RCU Forums > RC Helicopters > Electric RC Helis > Helimax
Reload this Page >

Glitches on startup?

Notices
Helimax This is for all your Helimax questions and comments.

Glitches on startup?

Old 05-18-2008, 12:02 AM
  #1  
dabigboy
Thread Starter
 
Join Date: May 2004
Location: Oklahoma City, OK
Posts: 299
Likes: 0
Received 2 Likes on 2 Posts
Default Glitches on startup?

Had my first serious mishap with the Axe last night (balled it up into the vertical shades on my sliding back door), fortunately no damage beyond finally nicking up the main blades enough to consider them toast.....well, and taking chunks out of 4 of the door shades. Anyway, today I'm noticing something weird. When I first plug in the battery, the main rotor will get a quick shot of power once or twice, usually starts a couple seconds after plugging in. Aside from being annoying, it's also dangerous, obviously. On startup, I'm doing the same thing I've been doing....extend antenna, throttle and trim to zero, TX on, then plug in the heli. It's still flying fine, no problems at all in-flight, and it doesn't do anything after I spool down on landing. Any ideas what the problem could be?
Old 05-18-2008, 10:52 AM
  #2  
PilotLight
Senior Member
My Feedback: (1)
 
PilotLight's Avatar
 
Join Date: Aug 2003
Location: Benton Harbor, MI
Posts: 1,027
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Glitches on startup?

Mine does the same thing. Its a glitch, usually caused by metal to metal contact somewhere. I found some bad solder joints on the connectors to the main motor. It still does it, not as often, though. Irritating!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.