Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > Himoto Racing Support Forum
Reload this Page >

Engine starts running when RC turns off

Notices
Himoto Racing Support Forum The Official Support Forum for Himoto Racing. Get all your questions answered here directly from the source.

Engine starts running when RC turns off

Old 01-16-2022, 03:40 AM
  #1  
pvremort
Junior Member
Thread Starter
 
Join Date: Jan 2022
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Engine starts running when RC turns off

Hi

Having some issues with our Himoto 1:10 truck. We have no experience in this. We replaced the ESC, and it seemed to work at first. Turn on car and RC, and basic controls work.

Now, when we turn OFF the RC (yes .. off) the engine revs up to full speed, and the only way to stop it is kill the power. Any suggestions ?

thanks !

Piet (Belgium)
Old 03-17-2023, 07:06 AM
  #2  
Big Alice
 
Join Date: Dec 2010
Location: Wenatchee, WA
Posts: 540
Received 23 Likes on 22 Posts
Default

Hard to tell from your post if you're doing this but you have to turn your transmitter on before you turn on the car. Also turn the car off before the transmitter is turned off.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Manage Preferences - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.