Go Back  RCU Forums > RC Helicopters > Hirobo Support Forum
Reload this Page >

lepton problem please help

Notices
Hirobo Support Forum Greg Gomes of MRC/Hirobo is your host. Ask all your Hirobo questions here!

lepton problem please help

Old 10-21-2007, 10:17 PM
  #1  
JordanT
Senior Member
Thread Starter
 
Join Date: Jan 2004
Location: Montreal, QC, CANADA
Posts: 171
Likes: 0
Received 0 Likes on 0 Posts
Default lepton problem please help

I just finished building my lepton, I flew two flights on it and everything is great except for one annoying problem. When I hit the ildle up switch while in flight the helicopter spins out of control for a couple of seconds. This almost caused me to crash the first time around and is still very difficult to handle even though I am now expecting it. What can the problem be? Everything in the radio programming is set up as per the manual including the throttle and pitch curves for normal mode and the idle ups so I find it strange that this would happen. I have owned several other hirobo helicopters and have helped many friends with theirs and this is the first time I encounter this problem. Anyhow hope someone can help and thanks in advance for any replies.


Jordan.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.