Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

605 question

Old 05-08-2002, 03:45 AM
  #1  
R Plante
Member
Thread Starter
 
Join Date: Mar 2002
Location: Stettler, AB, CANADA
Posts: 93
Likes: 0
Received 0 Likes on 0 Posts
Default 605 question

Mike

I was checking my ailerons on my Stinger 120 everything was good including range check.Started my Quadra 52 and the right aileron went to full deflection shut down everything was normal. Repeated 2 more times with same results.I am using 1 servo per aileron into a y connector. switched plugs in y connector same result.Futaba ends on the servo.

When I got home I pulled the servo and found the wires had been pinched and the black wire was 3/4 broke off right where it exits the case. I swapped the servo out with another 605 but haven't had a chance to test it yet but is it a good possibilty that it was my problem?

What is the cost to get a new end put on the servo if that is the causeof the problem.

Thanks
Randy
Old 05-08-2002, 03:30 PM
  #2  
MikeMayberry
Senior Member
My Feedback: (1)
 
MikeMayberry's Avatar
 
Join Date: Jan 2002
Location: Poway, CA
Posts: 3,531
Likes: 0
Received 0 Likes on 0 Posts
Default 605 question

The minimum labor charge is $12.50 plus parts.

Mike.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.