Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

What's wrong with my A9?

Old 08-03-2010, 12:55 AM
  #1  
Jerseydog
Junior Member
Thread Starter
 
Join Date: Jul 2010
Location: Carteret, NJ
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default What's wrong with my A9?

I just started using my Aurora 9 for the first time since I bought it a couple of month ago.I’m new to R/C and don’t know much about the hobby. I was reading the manual and trying to program the radio for a scratch build electric airplane I just built.Little by little I was getting the servos to move in the direction I wanted.Out of nowhere the module in the back of the radio started beeping with both Red and Blue LED on.If I move the rudder the engine wont move but the servos still do.I read the manual but can’t find anything that has to do with this problem.I did find the in flight warnings but it doesn’t say anything about the Red and Blue LED going on, which have me confused.I tried turning off and on the radio but the beeping just came back.Can someone tell me what’s wrong with my radio?All help is greatly appreciated.Thanks
Old 08-03-2010, 04:56 AM
  #2  
A.T.
Senior Member
 
Join Date: Jul 2002
Location: Auckland, NEW ZEALAND
Posts: 2,581
Likes: 0
Received 1 Like on 1 Post
Default RE: What's wrong with my A9?


ORIGINAL: Jerseydog I just started using my Aurora 9 for the first time since I bought it a couple of month ago.I’m new to R/C and don’t know much about the hobby. I was reading the manual and trying to program the radio for a scratch build electric airplane I just built.Little by little I was getting the servos to move in the direction I wanted.Out of nowhere the module in the back of the radio started beeping with both Red and Blue LED on.If I move the rudder the engine wont move but the servos still do.I read the manual but can’t find anything that has to do with this problem.I did find the in flight warnings but it doesn’t say anything about the Red and Blue LED going on, which have me confused.I tried turning off and on the radio but the beeping just came back.Can someone tell me what’s wrong with my radio?All help is greatly appreciated.Thanks
LED Status Card - What the colours/combinations are indicating.
. Digital .pdf copy which can be printed and inserted as a page in manual or extra cards made.

AFHSS - ID-Setup A.K.A, binding or linking & Range Testing Spectra Pro Module <> Optima Receiver

Aurora A9, Spectra Pro & Optima - FAQ & Undocumented Features - Mixes, Setups, Tips. {Individual Links often updated}

Regards
Alan T.
Alan's Hobby, Model & RC FAQ Web Links

Old 08-03-2010, 09:42 AM
  #3  
Brendan Lugo
Senior Member
 
Brendan Lugo's Avatar
 
Join Date: Nov 2004
Location: Poway, CA
Posts: 675
Likes: 0
Received 0 Likes on 0 Posts
Default RE: What's wrong with my A9?

Recharge your receiver battery.
Old 08-03-2010, 10:25 AM
  #4  
sgillmore
My Feedback: (50)
 
sgillmore's Avatar
 
Join Date: Jul 2003
Location: Jefferson City, MO
Posts: 294
Likes: 0
Received 0 Likes on 0 Posts
Default RE: What's wrong with my A9?

ORIGINAL: Jerseydog
Out of nowhere the module in the back of the radio started beeping with both Red and Blue LED on. If I move the rudder the engine wont move but the servos still do.
Can you give us a little more detail? You say the lights are on...are they solid or flashing? Be very specific.

I'm not an expert on this radio yet, but I think if you're experiencing a constant beeping from the module, it's either in powerdown or "range-check" mode or you're getting a low receiver battery warning.
Old 08-03-2010, 12:18 PM
  #5  
Jerseydog
Junior Member
Thread Starter
 
Join Date: Jul 2010
Location: Carteret, NJ
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default RE: What's wrong with my A9?

I just finished charging radio and I'm going to charge receiver battery. If this doesn't work I'll come back with more info. Thanks for the response.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.