Go Back  RCU Forums > RC Airplanes > Questions and Answers
Reload this Page >

THROTTLE JUMPS AROUND

Notices
Questions and Answers If you have general RC questions or answers discuss it here.

THROTTLE JUMPS AROUND

Old 07-08-2008, 05:07 PM
  #1  
flyhi
Senior Member
Thread Starter
My Feedback: (28)
 
Join Date: Dec 2001
Location: Near KC, MO
Posts: 124
Likes: 0
Received 0 Likes on 0 Posts
Default THROTTLE JUMPS AROUND

took plane to field, checked plane on stand, throttle servo worked great, very smooth servo function. fueled plane and started it, and the engine surges wide open, low, mid range, wide, and the throttle arm actually moves back and forth like jello sometimes. with throttle at idle it may suddenly go wide open or vice-versa. range checked radio and it's ok, is the throttle servo bad, receiver bad? all other controls work fine with no jumping. any suggestions? thanks
Old 07-08-2008, 09:03 PM
  #2  
Flying freak
Senior Member
 
Join Date: Jun 2006
Location: granby, QC, CANADA
Posts: 1,407
Likes: 0
Received 0 Likes on 0 Posts
Default RE: THROTTLE JUMPS AROUND

Any metal on metal contact around the push rod?

Steven
Old 07-08-2008, 09:35 PM
  #3  
flyhi
Senior Member
Thread Starter
My Feedback: (28)
 
Join Date: Dec 2001
Location: Near KC, MO
Posts: 124
Likes: 0
Received 0 Likes on 0 Posts
Default RE: THROTTLE JUMPS AROUND

don't think there is any metal to metal, unless you count connectors from split ailerons, got a long lead on there and it's kinda cramed into the fuse. linkage does move freely though
Old 07-09-2008, 03:13 AM
  #4  
Flying freak
Senior Member
 
Join Date: Jun 2006
Location: granby, QC, CANADA
Posts: 1,407
Likes: 0
Received 0 Likes on 0 Posts
Default RE: THROTTLE JUMPS AROUND

Was the range check with the engine running ?

I was more think about like a metal clevis on a metal carb arm

Steven
Old 07-09-2008, 06:50 AM
  #5  
Rodney
Senior Member
 
Join Date: Dec 2001
Location: FL
Posts: 7,769
Likes: 0
Received 1 Like on 1 Post
Default RE: THROTTLE JUMPS AROUND

Need more info to answer your query. Is this a glow engine or an ignition (spark plug) engine? If glow, does it have an onboard battery for the glow driver? Any other info on equipment brand, type, model, size of plane etc.
Old 07-09-2008, 12:32 PM
  #6  
flyhi
Senior Member
Thread Starter
My Feedback: (28)
 
Join Date: Dec 2001
Location: Near KC, MO
Posts: 124
Likes: 0
Received 0 Likes on 0 Posts
Default RE: THROTTLE JUMPS AROUND

the engine is my reliable tt .46. no on board glow. and no metal to metal contact. i'm thinking servo because the other controls, a, e, r work fine with no stuttering. guess i need to pull it and replace the throttle servo and see what happens. seems like receiver is fine, too, as i did range check it and again all other servos work fine.
Old 07-09-2008, 02:58 PM
  #7  
Rodney
Senior Member
 
Join Date: Dec 2001
Location: FL
Posts: 7,769
Likes: 0
Received 1 Like on 1 Post
Default RE: THROTTLE JUMPS AROUND

I think your diagnosis is right on, most probably a bad servo that acts up under vibration.
Old 07-09-2008, 04:32 PM
  #8  
jetmech05
 
Join Date: Jul 2005
Location: Jacksonville, FL
Posts: 4,855
Likes: 0
Received 0 Likes on 0 Posts
Default RE: THROTTLE JUMPS AROUND

when you say it range checked good what exactly do you mean? was the engine running and did the throttle servo respond correctly?
when the throttle started surging was the transmitter close to the receiver? could be you were having some over drive issues..this is where with the transmitter close to the receiver your actually over driving another channel and it appears on the throttle channel...the fix is to walk away a few feet....
Old 07-09-2008, 04:49 PM
  #9  
flyhi
Senior Member
Thread Starter
My Feedback: (28)
 
Join Date: Dec 2001
Location: Near KC, MO
Posts: 124
Likes: 0
Received 0 Likes on 0 Posts
Default RE: THROTTLE JUMPS AROUND

well, the throttle clevis is plastic, so i guess that's out. when i range checked it, i walked away about 50' and could not see the throttle, just a,e,r working fine. it works fine when engine not running, so i'm guessing bad servo under vibration. going to royals white sox game tonight so will be later this week before i can check it. i'll try to post solution when i find one to thank all for their comments and advice.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.