Notices
RC 1/8th Scale Buggies Discuss the ever popular category of 1/8th scale rc buggies in this forum!

Arrma typhon castle combo issues

Old 01-20-2021, 06:03 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2021
Location: Ocala fl
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Arrma typhon castle combo issues

I was out bashing around with my typhon yesterday I had a bad landing off a jump buggy had no power. So I got back home put it up on the table and it was giving me a radio glitch code. So I tried to bind it got nothing. I tried a different rx/tx got nothing. Then I realized the esc isn't sending power to my b-link either. So at that point I'd had enough and went in and had dinner and went to bed. Today I look at it again and it's turning on just to a red blinking light no sound or anything just a red blinking light. Any help will be much appreciated. Thank you
Old 01-28-2021, 04:09 PM
  #2  
 
Join Date: Oct 2013
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default

Check all wiring connections. Make sure there is no damaged wire/connection.
Make sure your battery is charged and has enough power.
RE-bind Tx/Rx successfully.
Reset/Re-calibrate ESC.

The red blinking light should be gone and everything should be back to normal.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.