Notices
RC Car General Discussions This forum is for all general discussions related to radio control cars. Check forums below for more specific categories if applicable.

Strange problem with Inferno Sport

Old 09-28-2003, 10:47 AM
  #1  
Kuma
Senior Member
Thread Starter
My Feedback: (1)
 
Join Date: Jun 2003
Location: Vancouver, BC, CANADA
Posts: 708
Likes: 0
Received 0 Likes on 0 Posts
Default Strange problem with Inferno Sport

Just bashing around with an MP7.5 Sport with my father, it seems to run well and cool (around 200-220) but isn't nearly as fast as my buggy (but much quieter). One problem is however everytime he jumps it and lands on all 4, the engine immediately cuts off and we haven't been able to figure out why, but I am guessing two possibilities: chassis flexing which would be hitting the center spur gear (the slot is very small) or the fuel tubing is too short which I replaced with longer preasure hose. He ordered some Kanai CNC chassis braces and should hopefully help. He uses a Futaba 3PJ, 5-cell 1100mah hump cell and Dynamite failsafe unit and the engine is a stock GX21.

Has anyone had this happen before or might know what causes the engine to immediatley cut out upon landings?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.