Go Back  RCU Forums > RC Helicopters > RC Helicopter General Discussions
Reload this Page >

S9551 servo question in turbine heli

Notices
RC Helicopter General Discussions Discuss RC Helis here. Nitro, gas, turbine and any make, model or brand not having its own specific forum below!

S9551 servo question in turbine heli

Old 03-08-2018, 12:54 AM
  #1  
Springbok Flyer
Thread Starter
 
Springbok Flyer's Avatar
 
Join Date: Jun 2006
Location: Gold Coast, Queensland, AUSTRALIA
Posts: 1,301
Received 1 Like on 1 Post
Default S9551 servo question in turbine heli

Hi guys,

I have been using these servos in my AirStar Hughes 500E Turbine heli since 2008. However I find that they need replacement quite often. When the first one just stopped working I ordered 4 from Tower Hobbies and replaced the culprit. But today I used up the last two I still had in stock. The power is 5.5volt so I am not putting more than 6 volt through them. Perhaps it is a heat problem. It seem to be the fore and aft (elevator) servos that die every time.

Your suggestions will be welcome. It will also be great if any alternative low profile servos can be suggested.

Regards,

JanR

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.