Notices
RC Robotics and Autonomous Robots Discuss autonomous and radio control robots and anything related to robotics in here

Servo Question

Old 07-29-2011, 02:17 PM
  #1  
dkeene
Junior Member
Thread Starter
 
Join Date: Jul 2011
Location: Weston, MA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Servo Question

Howdy All
I just bought a HS-805BB hitec servo. I have other servo's working fine but this just goes a few degrees forward and backward when I send information to it. I can rotate it gently and it's not stuck. Is this common? Is it broken?
I really need this to work!

Thanks
Doug
Old 07-29-2011, 03:49 PM
  #2  
lejongleur
Senior Member
My Feedback: (10)
 
Join Date: Feb 2008
Location: Norwalk, CT
Posts: 562
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Servo Question

Can you test it with a servo driver/tester? If you have, and the same tester worked fine with other servos, and you checked/rechecked the connections without success, you must have a bad servo. If you are using a receiver, switch it to another channel which you KNOW is working - if it doesn't work there, bad servo. If it DOES work in another channel, there could be a problem with the receiver.

Hope this helps...Chris
Old 08-02-2011, 08:48 AM
  #3  
JustHover
Junior Member
 
Join Date: Jan 2011
Location: Pekin, IL
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Servo Question

The 805 has the potential to draw a lot of current. What are you using to send control pulses to the servo?
Old 08-02-2011, 09:17 AM
  #4  
dkeene
Junior Member
Thread Starter
 
Join Date: Jul 2011
Location: Weston, MA
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Servo Question

Hi, All
Thanks for your help. Ispoke with the Manufacturer and he thought it was defective. Just my luck. I tried everything. The current was adequate. The servo driver drives other servos correctly.
Thankx

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.