Go Back  RCU Forums > RC Airplanes > RC Jets > Turbine Clinic > SimJet Turbine Direct Support
 2300GE fuel leaking problem... >

2300GE fuel leaking problem...

Notices
SimJet Turbine Direct Support Direct support for SimJet Turbines provided here.

2300GE fuel leaking problem...

Old 01-08-2005, 03:53 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Paris, FRANCE
Posts: 13
Likes: 0
Received 0 Likes on 0 Posts
Default 2300GE fuel leaking problem...

Hi,

I have a 2300GE.
I tested it for the first time today. I used the autostart system, the propane tank filled with a mix of 70/30 propane butane. The fuel used is a domestic fuel bought in a tool shop, mixed iwith 4% Shell Turbine 500.
I used the pump prime system for the first start, I heard the fuel pump running for 1 to 2 sec, then I put back the throttle down. The autostart began.
Big blue flame, the temp increasing, fuel ramp beginning then "running" appeared on the HDT. WOW a first try, a first success !!

I put the trim down to shut off the turbine to take a little rest (what a stress !!! )

I decided the try a second time. It was dark outside. I tried without the prime system. Then...nothing.....a big failure....no start.....just a white smoke, "low batt" on the HDT (but the battery was fully charged ...). I decided to try again with a prime. It worked, nice start again---"running" on the HDT---
BUT I noticed a big black spot on the wooden test bed just under the turbine itself. It was the fuel (??????), there was a leak !!! From where, I didnt know...
I washed the fuel and decided to try again to see where does the leak come from. And again a simple autostart didnt work and I had to prime the fuel system again....and again a leak.
Except that "little" problem, the turbine ran very well and responded nicely to the throttle command.

After a check of the turbine, the leak came from the under of ther turbine, near the blue cap scews and from the exhaust.

My question is : Did I do something wrong ? I think that using each time you want to start it the prime system is not normal. Maybe there was too much fuel that didnt burn in the combustion chamber and it would explain the BIG leak, but why ???

Here are my ECU settings :

Max speed : 122000
Idle speed : 26000
Stop speed : 20000
MAx temp : 848°
Min temp : 100°
Pump start point : Auto+0
Start Ramp : 5
Acc delay : 30
Dec delay : 30
Stab delay : 40


THANK YOU FOR YOUR HELP !!!

Antoine .
Old 01-09-2005, 11:35 AM
  #2  
Senior Member
 
Join Date: Dec 2001
Location: Milton, ON, CANADA
Posts: 972
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 2300GE fuel leaking problem...

Hi Antoine

Can you send me a picture of your setup? My e-mail is [email protected].

Ed
Old 01-09-2005, 12:21 PM
  #3  
My Feedback: (2)
 
Wayne22's Avatar
 
Join Date: Apr 2002
Location: Strathcona county, AB, CANADA
Posts: 5,394
Received 0 Likes on 0 Posts
Default RE: 2300GE fuel leaking problem...

FYI Ed..this is also posted here:

http://www.rcgroups.com/forums/showt...02#post3141202
Old 01-09-2005, 10:32 PM
  #4  
Senior Member
 
Join Date: Dec 2001
Location: Milton, ON, CANADA
Posts: 972
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 2300GE fuel leaking problem...

Hi Nony

Thanks for the heads up. I'm not a member of RCG yet.

Ed

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.