Notices
Tactic & AnyLink Support Forum Ask any questions you may have about AnyLink and Tactic systems here and get answers direct from their team.

trims not working correctly on the ttx650

Old 07-29-2013, 05:36 PM
  #1  
Junior Member
Thread Starter
My Feedback: (1)
 
Join Date: Jan 2005
Location: valencia, PA
Posts: 4
Likes: 0
Received 0 Likes on 0 Posts
Default trims not working correctly on the ttx650

I have a friend that has a ttx650 he switched to mode one but when you reverse any of the channel the trims work the opposite direction. I have one on mode 2 and I reverse any channel it works correctly. my friend called hobby services and thay said that is normal and that is not normal. any ideals thank you.
Old 08-07-2013, 06:24 AM
  #2  
Bax
My Feedback: (11)
 
Join Date: Apr 2002
Location: Monticello, IL
Posts: 19,483
Likes: 0
Received 6 Likes on 5 Posts
Default

What do you mean that when you have the transmitter in Mode I, the trims are backwards? Do you mean that when you change to Mode I, and, say, the elevator servo moves clockwise when you move the elevator stick to the "up" position, that when you reverse the channel in the transmitter so that the elevator servo then moves counter-clockwise for "up", adding trim for "up" makes the servo move clockwise? That would not be correct, of course. When you give "up" elevator, moving the trim in the same direction as the stick should make the servo move in the same direction.

Please give us some more clarification. What is actually happening?
Old 08-07-2013, 02:08 PM
  #3  
Junior Member
 
Join Date: Apr 2012
Location: glenshawpa
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Question trims not working correctly

Bought new Tactic TTX650 trans MAY 2013.Installed in airplane July.CHanged to Mode 1.Needed to reverse elevator and throttle channels.First flight needed to add down trim for level flight.While moving trim switch forward (up) I acually received up trim.Back on the ground I discovered the trim does not reverse with the channel reverse on any channel that you reverse. Trim stays same as when channel is in the non reversed status.Called Service Dept and explained situation.they told me that is NORMAL.THAT IS NOT NORMAL.Have 9 other trans of various brands and all work correctly.Have friends with Tactic 650 trans witch all work correctly when channels are reversed.WHAT GOES.SORRY FOR THIS PURCHASE.Have since sent trans to Service Dept on 8 /5/13.Not to optamistic.
Old 08-08-2013, 06:24 AM
  #4  
Bax
My Feedback: (11)
 
Join Date: Apr 2002
Location: Monticello, IL
Posts: 19,483
Likes: 0
Received 6 Likes on 5 Posts
Default

Your experience is NOT NORMAL. I'd not know who you talked to. When I changed my TTX650 to Mode I the trim next to the elevator stick (former throttle stick), it moved the channel in the proper directions. When I reversed the channel, the trim still worked in the proper direction, so that when I reversed the stick's action, the trim action followed. So, "up" elevator on the stick and "up" elevator on the trim always matched. Something is goofy with your transmitter.
Old 08-08-2013, 07:30 AM
  #5  
Junior Member
 
Join Date: Apr 2012
Location: glenshawpa
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks to Bill Bax for your thoughts and support. Was beginning to think I was the goofy one. Hope the Service Dept agrees there is a problen and that it is NOT NORMAL.
Old 08-10-2013, 12:08 PM
  #6  
Senior Member
 
Join Date: Dec 2001
Location: FL
Posts: 7,769
Likes: 0
Received 5 Likes on 5 Posts
Default

Perhaps a matter of symantics. When Post #3 said he reversed the elevator and throttle channel, I think he meant "interchanged"; i.e. moved the throttle to the right hand stick and elevator to the left hand stick. He did not reverse each channel.
Old 08-10-2013, 06:18 PM
  #7  
Junior Member
 
Join Date: Apr 2012
Location: glenshawpa
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Rodney: I changedthe trans to Mode 1 which I have flown for 40 years .changing the mode has nothing to do with the direction the servos move.Then to fly the airplane I neededto change the direction of the elevator and throttle due to the instalation.When I reversed those channels the servos change direction but the trim did not follow.This I dicovered in the air on the first flite.I needed some down trim for level flite.As I attemted to obtain down trim by pushing forward on (UP) on the trim I received UP trim.To receive down trim I actually had to pull up trim.no matter what channel I reverse,the trim does NOT follow.No symatics envaulved.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.