Notices
Wren Turbines USA Wren USA no longer providing support for their turbines. We are converting this forum into a member supported support forum. This means members will solve members problems

Gas solenoid source

Old 07-12-2022, 10:41 AM
  #1  
Grodus
Thread Starter
 
Join Date: Mar 2006
Location: Hensley, AR
Posts: 390
Likes: 0
Received 0 Likes on 0 Posts
Default Gas solenoid source

Iím having a problem with a gas solenoid on my Wren Supersport. It works some starts but during others, it sticks closed and will open if I beat on it with a screwdriver. When it does function, the starting EGT is being exceeded. Not sure if both problems are related. Does anyone know where I can find a Jet Tronics gas valve that is compatible with this engine? I can not find one.

thank you,
Cody
Old 07-12-2022, 11:14 AM
  #2  
joeflyer
My Feedback: (48)
 
Join Date: Dec 2001
Location: Plymouth, MI
Posts: 2,954
Likes: 0
Received 15 Likes on 13 Posts
Default

https://www.turbinesolutions.co.uk/t...s?pagenumber=4
Old 07-12-2022, 02:24 PM
  #3  
Grodus
Thread Starter
 
Join Date: Mar 2006
Location: Hensley, AR
Posts: 390
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you Joe!

cody
Old 07-13-2022, 05:07 AM
  #4  
Grodus
Thread Starter
 
Join Date: Mar 2006
Location: Hensley, AR
Posts: 390
Likes: 0
Received 0 Likes on 0 Posts
Default

Does the gas solenoid modulate during the start sequence or is it simply open or closed?
Old 07-13-2022, 06:27 AM
  #5  
basimpsn
My Feedback: (5)
 
Join Date: Dec 2001
Location: Mia, FL
Posts: 2,580
Received 4 Likes on 4 Posts
Default

Some ecu modulate the valve to control the gas flow...Others supply 5v to fully open the valve but install a restrictor inside the gas supply line
Old 07-13-2022, 10:53 AM
  #6  
CARS II
My Feedback: (7)
 
CARS II's Avatar
 
Join Date: Oct 2002
Location: Sacramento CA
Posts: 6,589
Received 122 Likes on 106 Posts
Default

Sounds to me that what it needs a is a few drops of 3 in 1 oil to help it get loose.
Old 07-13-2022, 02:14 PM
  #7  
Grodus
Thread Starter
 
Join Date: Mar 2006
Location: Hensley, AR
Posts: 390
Likes: 0
Received 0 Likes on 0 Posts
Default

Part of if not all of my problem was an ECU batt that showed charged voltage but couldn’t handle a load. Went to a new bigger battery and starts are normal temps and the solenoid worked every time. I monitored the solenoid with a stethoscope before doing a full start and it worked ever time.
Old 07-13-2022, 04:08 PM
  #8  
CARS II
My Feedback: (7)
 
CARS II's Avatar
 
Join Date: Oct 2002
Location: Sacramento CA
Posts: 6,589
Received 122 Likes on 106 Posts
Default

Thank you for reporting back.

It's always educational to learn the solutions to the problems.

The gas solenoids need a few drops of oil ( 3&1or Teflon ) every now and then because the gas is cold and it tends to dry them leading to getting stuck.
Old 07-13-2022, 06:31 PM
  #9  
Grodus
Thread Starter
 
Join Date: Mar 2006
Location: Hensley, AR
Posts: 390
Likes: 0
Received 0 Likes on 0 Posts
Default

Thank you Cars. I have been operating this engine for 10 years and I had no idea about lubing the valves. I have been operating LiPos for much longer and just got an education on how a $20 batt can fall on its arse and cause problems.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.