Notices
Car Nitro & Gas Engines Discuss all aspects of Nitro and Gas rc car engines here!

OS .21tm Not reaching max rpm on Revo

Old 08-07-2022, 06:57 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2022
Location: Mobile, Alabama
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default OS .21tm Not reaching max rpm on Revo

I have just reached full break-in and have attempted adjusting HSN and LSN on my OS .21TM in my TRX Revo. I just cannot get max rpms or get it to wheelie like many videos on YouTube...
What should I do? What is average needle setting for max performance?
Thanks in advance for any help...

Last edited by Marko36608; 08-07-2022 at 07:01 PM.
Old 05-29-2024, 02:52 AM
  #2  
Junior Member
 
Tmaxx26and28maxreddots's Avatar
 
Join Date: May 2024
Location: Lexington,ky
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default No wheelies?

Hey Marko, there could be a hundred different factors causing what you're talking about. This is a stock Revo? Stock gearing? Have you added aluminum? Is it the 25 or the extended 3.3 version. Stock tires? Or larger diameter? What brand and percentage fuel are you running? My opinion, stay away from Traxxas fuel. VP is a decent off the shelf fuel. What glow plugs are you running? Hot? medium? How about exhaust? Are you running the resonator that came on the revo? If so I recommend Drilling the outlet by at least a 16th of an inch or 1.5 mm. I have a big block T-Maxx was running great, tore down to replace the diffs, got it back together took it for a spin, and was stalling out on the high end. Good mid-range power good low-end power, turns out the O-ring on my fuel tank cap wasn't tight enough. Turns out had that problem all along only Didn't notice it before because I was running a stock Traxxas header. While doing the diff swap put a THS high flow header in its place. I was starving for fuel on the high end. Are you running a fuel filter? One grain of sand can destroy your engine. He could have a hole in the pressure line from me exhaust to the tank. I currently do not have a TM, the only OS engine I have right now is a modded xz.21. And it is a screamer. My advice try to find someone running the same setup as you that it's not having this issue find out what glow plugs they're using and what type of fuel, what gear ratios on the CB / spur, and check all the simple things. Fuel lines, filter, fuel cap seal, if all of that is okay, then you're probably just looking at a tuning issue, or a engine air leak. If all else fails and you're ready to give up on it, the os xz 21 I have the sitting on the shelf, I don't think I will ever use it. $150 you can have it. And I'll give you a warranty for 10 days after you receive it. That would be plenty of time to bolt it on and dog it enough to know it's a good engine. Good luck with your TM!!!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.