Go Back  RCU Forums > Electric Aircraft Universe > Electric RC Jets
Reload this Page >

Question about 60Amp E-Flite ESC

Notices
Electric RC Jets Discuss rc electric ducted fan or radio control prop jets here.

Question about 60Amp E-Flite ESC

Old 08-26-2011, 02:20 PM
  #1  
gsxphil
Junior Member
Thread Starter
 
Join Date: Dec 2010
Location: Martinsburg, WV
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default Question about 60Amp E-Flite ESC

I have a brand new PNP Habu that I was setting up with my Hitec Aurora 9 radio. I havent flown the plane yet but I had everything working. I have a Castle Creations BEC 10 Amp installed for the reciever power. I cut the red wire from from the ESC for power going to the receiver like you are supposed to do. Right out of the blue the throttle quit working. I installed a spare fan/motor and still didnt work. Swapped out the servo wires with no help. I am at a loss. Only thing I can think is that the ESC went bad. I didnt let the smoke out lol. But just suddenly stopped working. I did check my channel 3 on my radio to make sure it wasnt radio or receiver and that all checked out fine. Any help would be greatly appreciated. Thanks, Phil
Old 08-26-2011, 02:34 PM
  #2  
gsxphil
Junior Member
Thread Starter
 
Join Date: Dec 2010
Location: Martinsburg, WV
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Question about 60Amp E-Flite ESC

Nevermind. I Googled it and found someone that had the same problem. They got a reply to lower the throttle trim all the way down. Well what do you know. It worked. No more problems. Thanks,.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.