Notices
Futaba Radios Direct support forum Ask any questions you may have about Futaba radios and product here and get answers direct from Futaba

SZ16 problem

Old 10-13-2021, 05:48 AM
  #1  
Maddmaxx1
Junior Member
Thread Starter
 
Join Date: Jan 2021
Posts: 13
Likes: 0
Received 4 Likes on 2 Posts
Default SZ16 problem

My Futaba 16SZ sometimes has a problem where it shows the Life battery drops very fast to 6.0 volts but the battery is just fine and was charged that day. I even did a discharge on the pack to make sure the capacity was still good and it was. When it happened I turned the radio off and then back on and it still did the same. Showed 6.6 volts and the went down to 6.0 within a few seconds. When I got home it was working ok. Have seen the radio do this about 4 times.

The radio is set to life pack. I am afraid that I will end up losing an expensive plane because of this.
Would send it to Futaba but it only does this at random and they may never see it happen.
Old 10-13-2021, 05:58 AM
  #2  
FUTABA-RC
 
FUTABA-RC's Avatar
 
Join Date: Oct 2017
Posts: 1,165
Received 20 Likes on 20 Posts
Default

Hi - if it is doing this with a fully charged pack then it is either a faulty pack or a software glitch. You can either grab a new pack (several after market packs available) or send it to service to get the TX checked.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.