Go Back  RCU Forums > RC Helicopters > Electric RC Helis > Helimax
Reload this Page >

Swashplate question

Notices
Helimax This is for all your Helimax questions and comments.

Swashplate question

Old 03-01-2009, 01:58 PM
  #1  
cruiser1956
Junior Member
Thread Starter
 
Join Date: Oct 2008
Location: Fond du Lac, WI
Posts: 10
Likes: 0
Received 0 Likes on 0 Posts
Default Swashplate question

My swashplate on my cpv3 came apart after a lite crash. It seems as thoght I can just push it back together. My queastion is one rings has the connectors to the servo linkage and the other goes to the blade control arms. How do I know how to orient them.
Old 03-03-2009, 11:00 AM
  #2  
Shadow99
Senior Member
 
Join Date: Aug 2007
Location: Southwick, MA
Posts: 511
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Swashplate question

Here's a few pics of the AXE CP with the Bell-Hiller rotorhead, hope this helps.

Shadow
Attached Thumbnails Click image for larger version

Name:	Zx71709.jpg
Views:	14
Size:	64.8 KB
ID:	1149337   Click image for larger version

Name:	Fa85283.jpg
Views:	13
Size:	47.6 KB
ID:	1149338  
Old 03-22-2009, 06:38 PM
  #3  
niteliter
Senior Member
My Feedback: (1)
 
Join Date: Jan 2009
Location: Chesapeake, VA
Posts: 138
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Swashplate question

This may help too/
http://public.fotki.com/afreelancer/...heli-max-cpv3/
Old 04-07-2009, 02:53 PM
  #4  
bighuhu
Junior Member
 
Join Date: Sep 2008
Location: Pleasant Hill, CA
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Swashplate question

I had the same problem, 1956. I believe that the two pieces should be a press fit. I cleaned the two parts, then I put a small drop of zap a gap on the top piece, then slid it into the lower part. You don't need to be concerned how to orient it since it is a bearing. Be careful not to get any cement into the the bearing itself.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.