Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

Powersafe RXs and HS7950 servos

Old 04-22-2010, 06:46 PM
  #1  
hbutler
Thread Starter
 
Join Date: Jul 2007
Location: san jose, CA
Posts: 97
Likes: 0
Received 0 Likes on 0 Posts
Default Powersafe RXs and HS7950 servos

There has been forum post on 7950 servos not working well at high voltage with extensions longer than 24inchs... Cody Wojcik from hitech states that their data shows that the signal strength put out by the powersafe RXs is not strong enough to run the servos at high voltage. I have a JR1222 that I would like to use with these servos at high voltage. The current suggested fix is to put one of your inline signal boosters on the servo extension. http://www.spektrumrc.com/Products/D...x?ProdID=SPMCP Do you have conclusive data that shows the suggested will fix the problem. Results on forum post seem mixed. Secondly are their any fix this problem? I have over $200 invested in my rx and I don't want to have to add/replace with another solution. I would really prefer not to use the signal booster.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.