Notices
KingTech Turbines International Barry is your host and will help you with all your Kingtech questions and concerns.

King Tech Turbine Engine

Old 05-19-2020, 01:19 AM
  #1  
Vendata
Thread Starter
 
Join Date: Aug 2004
Location: Christchurch, NEW ZEALAND
Posts: 179
Likes: 0
Received 0 Likes on 0 Posts
Default King Tech Turbine Engine

Hey Guys,
Just wondering if any body has had trouble with King Tech turbine pumps?? I have a 100 king tech kero start about 25 hours on the engine & the pump crapped out, I have a filter in the main tank, header tank has a filter in it. Has another filter in the jet after the pump prior in going through the shut off valve. Just stop running so have replaced with a new one from King Tech. As I also have a 80 King Tech propane start with about the same hours on it that pump went as well, & had to replace with a new one as well. Just cant understand what is going on, even the fuel i use is strained prior in going into my 10 litre fuel container. Has any body else having trouble with there pumps! could any body share some thoughts what could be happening or is it the pumps just don't last?? I look forward for some body to give me some sort of advice.
Thanks
Dave.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.