Notices
RC 1/8th Scale Buggies Discuss the ever popular category of 1/8th scale rc buggies in this forum!

hyper 7 4port engine help!

Old 04-01-2005, 10:40 AM
  #1  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default hyper 7 4port engine help!

Hey,

I got a hyper 7 after christmas and got it running right away the first time of trying after about two pulls, but then the pullstart broke so i brought the non-pullstart back plate and starting saving up for a starter box, which i got the other day. Anyway the car wont suck fuel up into the engine now so it wont start, if i put some fuel directly into the engine it starts but then cuts out when its all burnt up, so im thinking theres an air leak somewhere stopping fuel being sucked in? Ive had many nitro cars and this is the first time ive had this problem so any help would be greatly appreciated!

This is my first 1/8th scale buggy after getting bored with 1/10th on road nitro and i seem to be pouring tons of money into it but never actually getting it to work!

James
Old 04-01-2005, 10:53 AM
  #2  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

OK, little trick for you here. When you first start it up, block the exhaust and watch the fuel fly though.
Old 04-01-2005, 10:56 AM
  #3  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Sorry i didnt state that before, it doesnt suck up fuel when blocking the exhaust, as i no you have to do that to get fuel into the engine, but it still doesnt move, which is why i think its an air leak?
Old 04-01-2005, 11:01 AM
  #4  
Galifrey
Senior Member
 
Galifrey's Avatar
 
Join Date: Dec 2002
Location: Northants, UNITED KINGDOM
Posts: 1,194
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

More likely to be a blockage somewhere or a pinch in the fuel line...

blow in the pressure feed and see if that forces the fuel up, if not then start thinking about flushing the carb thru

Old 04-01-2005, 11:03 AM
  #5  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

hmmm, yea ive blown into the pressure line and that forces fuel up, so i think im going to take the engine out and give it a good clean and check its all fine inside.
Old 04-01-2005, 04:35 PM
  #6  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!


ORIGINAL: JamesJenkins

hmmm, yea ive blown into the pressure line and that forces fuel up, so i think im going to take the engine out and give it a good clean and check its all fine inside.
No. It's more likely the carb isn't setup right. Put it back to factory setings and try again.
Old 04-01-2005, 04:43 PM
  #7  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

http://www.rcuniverse.com/forum/Brea...2810696/tm.htm
Old 04-01-2005, 04:57 PM
  #8  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

It is already set at factory settings AND i printed that sheet out you wrote to use before. Thing is it worked before and nothing has been changed accept removing pullstart/putting on non-pullstart backplate.
Old 04-01-2005, 05:08 PM
  #9  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

is it turning over? Did you fit the new backplate with the groove at the top?
Old 04-01-2005, 05:10 PM
  #10  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Yep its turning over and yes i did fit that backplate.
Old 04-01-2005, 05:14 PM
  #11  
MassiveMods
Senior Member
 
MassiveMods's Avatar
 
Join Date: Nov 2003
Location: SydneyNSW, AUSTRALIA
Posts: 1,565
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

i had the exact same problem when i first got my hyper .. check where your bottom end is .. richen both bottom and hsn by 1/4 turn .. its the carb thats doing it.. hypers have dodgy carbs..

If that dosent work open up the HSN by turning it all the way out and see if there is an obstruction.. like a piece of rubber or something .. also when you have the HSN out check that you have a clear passage from the recieving collar to the fuel jet..

failing this you can buy a new carb .. OS 20 e , any RB or Novarossi carb will do it.. In fact any 21 up to 26 carb that fits will do it.. (preferance in that order)

Good Luck
Old 04-01-2005, 05:17 PM
  #12  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Ok, thanks, il have a go tomorrow and see what happens! Thanks for the advice!
Old 04-01-2005, 05:24 PM
  #13  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Anyone know any UK shops who sell the OS 20e carb? i would order from tower but you get caught with import tax now from the US, so if anyone knows any UK sites i would appreciate it.
Old 04-01-2005, 05:26 PM
  #14  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

try ebay.co. uk
Old 04-01-2005, 05:37 PM
  #15  
MassiveMods
Senior Member
 
MassiveMods's Avatar
 
Join Date: Nov 2003
Location: SydneyNSW, AUSTRALIA
Posts: 1,565
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

if you see any Rossi or picco carbs try them they are actually just as good if not better than the 20 e
Old 04-01-2005, 05:38 PM
  #16  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Thanks but theres nothing on ebay, even searched for items internationally, so i guess il have to get from tower if i want that carb.
Old 04-01-2005, 05:43 PM
  #17  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

I cant seem to find any carbs anywhere, ebay or UK shop websites....
Old 04-01-2005, 05:54 PM
  #18  
MassiveMods
Senior Member
 
MassiveMods's Avatar
 
Join Date: Nov 2003
Location: SydneyNSW, AUSTRALIA
Posts: 1,565
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

let me know how you go .. i have a new rossi carb and an old RB i can let go of i guess...
Old 04-01-2005, 05:57 PM
  #19  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

how much would you want for the new rossi carb...?
Old 04-01-2005, 08:04 PM
  #20  
MassiveMods
Senior Member
 
MassiveMods's Avatar
 
Join Date: Nov 2003
Location: SydneyNSW, AUSTRALIA
Posts: 1,565
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

45 usd which is about 3 squid lol

or try this link

http://cgi.ebay.com/ws/eBayISAPI.dll...sPageName=WDVW

just put the search on 21 carb or picco carb or rossi carb on ebay .. you should find some easy..
Old 04-02-2005, 05:08 AM
  #21  
Da Smak
Banned
 
Join Date: Feb 2004
Location: North of the, , UNITED KINGDOM
Posts: 6,058
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

If you fancy a day out, then come down to the Swindon track before 1pm tomorrow. I'll get it runing for you.

www.swindon-nitros.com
Old 04-02-2005, 06:25 AM
  #22  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Sorry but im only 17 and have no way of getting down to swindon, thanks for the offer though.
Old 04-02-2005, 09:17 AM
  #23  
JamesJenkins
Senior Member
Thread Starter
 
Join Date: Dec 2003
Location: kidderminster, UNITED KINGDOM
Posts: 202
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Ok, i messed with the LSN and opened it up a little and the car started right away! So thanks for that tip massivemods! Ive run two tanks of fuel through it at idle so far and everything seems to be going ok! Thanks for all the help!
Old 04-03-2005, 05:16 AM
  #24  
MassiveMods
Senior Member
 
MassiveMods's Avatar
 
Join Date: Nov 2003
Location: SydneyNSW, AUSTRALIA
Posts: 1,565
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

AWESOME !! happy days !
Old 04-03-2005, 11:23 AM
  #25  
thopper
Senior Member
 
Join Date: Nov 2004
Location: Fullerton, CA
Posts: 746
Likes: 0
Received 0 Likes on 0 Posts
Default RE: hyper 7 4port engine help!

Make sure that you have the carb open. Without air coming into the carb (pull on throttle) there will be no vacum. Put fingure over exhaust and pull trigger ,bump start and fuil will go threough air leak or not!

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.