Notices
RC Electric Off-Road Trucks, Buggies, Truggies and more Discuss electric RC off-road, buggies & trucks here. Also discuss brushless motors, speed controllers aka ESC's, brushed motors, etc

Traxxas Slash 1/16 NOT POWERING ON

Old 10-24-2013, 11:01 PM
  #1  
meloman408
Junior Member
Thread Starter
 
Join Date: Nov 2011
Location: san jose, CA
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
Default Traxxas Slash 1/16 NOT POWERING ON

Tried swapping batteries and messing with the receiver but got nothing. What I have right now is a good battery connected with the receiver taken apart both the ESC and steering servos are plugged in to the right channels. The funnt things is that it was doing this even before I took it apart because I must of had a faulty battery as my other identical Traxxas also started having problems. I got that one working now but with that one at least I would get a red light. Don't know where to go from here any suggestions would be appreciated.
Old 10-25-2013, 04:20 PM
  #2  
phmaximus
 
phmaximus's Avatar
 
Join Date: Jun 2008
Location: Adelaide, AUSTRALIA
Posts: 6,709
Likes: 0
Received 2 Likes on 2 Posts
Default

Un plug ur steering servo... Then test again.

if it works with it unplugged its the servo failed.... Very common.... Replace with non traxxas servo lol

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.