Notices
T-Rex heli For all you T-Rex lovers out there, this where you can post!

450s flybar help

Old 12-29-2007, 05:30 PM
  #1  
Big feet
Senior Member
Thread Starter
 
Big feet's Avatar
 
Join Date: Aug 2005
Location: Carrickfergus, UNITED KINGDOM
Posts: 812
Likes: 0
Received 0 Likes on 0 Posts
Default 450s flybar help

Hi all,
I have just bought a Trex 450s, pre built. During the inspection that I obviously carried out I noticed that there is about 1mm of play on the flybar. The flybar control arms are tight to the flybar control rods so I am left wondering how to remove this play.
Is the 1mm of movement normal?? Or should I get some thin washers and eliminate the movement totally?
My mate who is totally new to helis built his 450s from a kit and he has the same 1mm of movement.

Please excuse the poor diagram, its not my best sketch ever.

Any suggestions would be most helpful, thanks.
Attached Thumbnails Click image for larger version

Name:	Wu61643.jpg
Views:	17
Size:	17.3 KB
ID:	836696  
Old 12-29-2007, 05:44 PM
  #2  
ct420
Senior Member
 
Join Date: Mar 2006
Location: mansfield, TX
Posts: 1,195
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 450s flybar help

It's most likely because the flybar cage is not 'capturing' the see-saw tightly enough. With the plastic flybar cage, you have to squeeze it together to capture the bearings in the see-saw while tightening down the screws that hold the flybar. A lot of people fail to do that, and end up with 'end play' in the flybar system as you have described. I suggest you fix it, as it is not a good thing
Old 12-30-2007, 01:13 AM
  #3  
T/Aguy
Senior Member
 
T/Aguy's Avatar
 
Join Date: Oct 2007
Location: Stockbridge, GA
Posts: 144
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 450s flybar help

double check Ball links??
Old 12-30-2007, 11:59 AM
  #4  
Big feet
Senior Member
Thread Starter
 
Big feet's Avatar
 
Join Date: Aug 2005
Location: Carrickfergus, UNITED KINGDOM
Posts: 812
Likes: 0
Received 0 Likes on 0 Posts
Default RE: 450s flybar help

Thanks for the help guys,
I did a search here on RCU and found simular questions from other trex owners.
I bit the bullet last night and striped the assembly down and added a washer, free play gone.

Thanks everyone

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service -

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.