Notices
Hitec/MultiPlex Radios- Ask Hitec Customer Service Ask Hitec/MultiPlex Customer Service your Radio questions here.

Intermitant blue module light when servos are use

Old 11-18-2010, 07:19 PM
  #1  
jwgn
Junior Member
Thread Starter
 
Join Date: Nov 2005
Location: new york, NY
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Intermitant blue module light when servos are use

The blue light on my Hitec 2.4 module lights on and off and beeps when I apply the aileron servos All other servos are ok and no light.The aileron servos are digital. I have a fully charged battery pack ( ni cads) 5 cell 1800 ma. The batteries test ok on my load tester. Any suggestions?
Old 11-18-2010, 07:44 PM
  #2  
coriolan
 
coriolan's Avatar
 
Join Date: Sep 2006
Location: Canada
Posts: 885
Received 0 Likes on 0 Posts
Default RE: Intermitant blue module light when servos are use

Sound familiar!
http://www.rcuniverse.com/forum/m_9932022/tm.htm
Old 11-18-2010, 07:52 PM
  #3  
A.T.
Senior Member
 
Join Date: Jul 2002
Location: Auckland, NEW ZEALAND
Posts: 2,581
Likes: 0
Received 1 Like on 1 Post
Default RE: Intermitant blue module light when servos are use


ORIGINAL: jwgn The blue light on my Hitec 2.4 module lights on and off and beeps when I apply the aileron servos All other servos are ok and no light.The aileron servos are digital. I have a fully charged battery pack ( ni cads) 5 cell 1800 ma. The batteries test ok on my load tester. Any suggestions?

What voltagelevel is theSpectra Module set at?
Low Battery Warnings - Minimum Settings Recommended for both the Aurora TX & Spectra 2.4GHz module - which are set separately.

if at the recommended 4.5V, this indicates that:
. RX battery cannot handle the current requirements of yourtotal servos, many load testers cannot test NiMH or A123.
.
Faulty leads or connections.

AFHSS - Warning Beeps Aurora & Spectra Pro. - meanings
LED Status Card - What the colours/combinations are indicating.

Aurora A9, Spectra Pro & Optima - FAQ & Undocumented Features
- Mixes, Setups, Tips.

Regards
Alan T.
Alan's Hobby, Model & RC FAQ Web Links
Old 11-18-2010, 08:53 PM
  #4  
jwgn
Junior Member
Thread Starter
 
Join Date: Nov 2005
Location: new york, NY
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Intermitant blue module light when servos are use

I have an Eclipse transmitter. How do I reprogram the module? Do I need a ubs cable? I will be upgrading batteries for my receiver just to be safe.
Old 11-18-2010, 10:56 PM
  #5  
A.T.
Senior Member
 
Join Date: Jul 2002
Location: Auckland, NEW ZEALAND
Posts: 2,581
Likes: 0
Received 1 Like on 1 Post
Default RE: Intermitant blue module light when servos are use


ORIGINAL: jwgn I have an Eclipse transmitter. How do I reprogram the module? Do I need a ubs cable? I will be upgrading batteries for my receiver just to be safe.
Hitec HPP-22 2.4GHz Programmer - Manual, FAQ - How to install & Use Instructions (with screenshots).
However, the module supplied separately should have had the factory auto detect 4/5cell saved at 4.5v.
What chemistry are the batteries?
Optima Transceiver (RX) - A123 2S Cell - Low Battery Warning not adjustable V1.04<06. Setting Voltage Alerts V1.07. Warning regarding use of Eneloop & A123 2S as RX batteries.
Optima Transceiver (RX) - Battery set up for Nitro/Gas models #1 caution re NiMH.
Optima Transceiver (RX) - Battery set up for Nitro/Gas models #2 caution re NiMH.

Alan T.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell or Share My Personal Information -

Copyright © 2023 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.